1. Welcome to The Audio Annex! If you have any trouble logging in or signing up, please contact 'admin - at - theaudioannex.com'. Enjoy!
    Dismiss Notice
  2. HTTPS (secure web browser connection) has been enabled - just add "https://" to the start of the URL in your address bar, e.g. "https://theaudioannex.com/forum/"
    Dismiss Notice

New phono cartridge problems.

Discussion in 'Source Components' started by Dentman, Jul 23, 2018.

  1. Dentman

    Dentman Well-Known Member

    After installing a new Ortofon MM cartridge in my Realistic Lab 400 turntable I have no right channel. I reconnected it several times and all connections are tight. Acording to the color code on the new cartridge that's correct also.
    Just put the old sure back in and all is fine. Any ideas?
     
  2. JeffMackwood

    JeffMackwood Maxi-Me

    Breaking News!!

    Dentman has gone completely to the left!!!!!

    You read it here.

    Definitely NOT FAKE NEWS!

    Who woulda ever thunk it!?
     
    Dentman likes this.
  3. rammisframmis

    rammisframmis Well-Known Member

    Isn't "Realistic" and "Lab" an oxymoron?

    At any rate, it sure sounds like your Ortofon is defective in one channel. You might take a resistance measurement at the end of the RCA cable to see if the two sides measure somewhat equally.
     
  4. Dentman

    Dentman Well-Known Member

    Ok so no chance something crazy is going on like my geometry is so far off that I'm only tracking 1 channel?
     
  5. rammisframmis

    rammisframmis Well-Known Member

    I can't rule out anything since I'm not where you are, but it sounds like the cartridge is defective. Have you done the resistance measurement? If a coil is open, that measurement will catch it.
     

Share This Page